[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: name conflicts

Montreal Wed May 27 23:04:48 1998

At one point in cyberspacetime,
Etienne Gagnon <egagnon@sprynet.com> wrote:

> - Class name are longer
> - "_" is not nice in a class name (aesthetics)

Sounds good to me, using _ would probably be justified in this case
and it doesn't really increase the class name all that much (you'll
only ever have one _ added, right).

> If we do this, we could as well change the order of names so that:
> statement = {if} ... | {for} ...;
> gives:
> Statement_If_Alt, Statement_For_alt, Statement_Prod

I'm not sure if reversing the order is all that nice, might just take
some getting used to.

> By experience (SableCC 1.0), using numbers is not good. It results in
> confusing alternative names. (e.g. ASatement5, ASatement6 do not help in
> knowing which one is the FOR or the IF statement.)

Somehow I doubt any kind of automatic naming would come up with nice
programmer-friendly class names.